User Tools

Site Tools


Sidebar


Здравствуйте!

Меня зовут Михаил!
Я системный администратор
и наполняю эту wiki,
решая разнообразные IT-задачки.

Моя специализация - виртуализация!

Я всегда готов помочь Вам
наладить IT-инфраструктуру
за скромное вознаграждение!

mike@autosys.tk
+7 (910) 911-96-23

linux_faq:обновление-виртуальнои-машины-xenserver-5-5-debian-5-lenny-до-debian-6-squeeze

Here is what I just did step-by-step

1) Backup! I take no responsability if this would break your system.

2) Update to Debian 5.0.9
# apt-get update
# apt-get upgrade
# reboot
3) # nano -w /etc/apt/sources.list
Change lenny to squeeze. Comment out the two volatile lines. They seem not to be used anymore.

4) Update to Debian 6
# apt-get update
# apt-get upgrade
During installation:
“Services to restart for PAM library upgrade": If cron is deafult - use this.
If /etc/console-tools/config has changed - Keep your change with N (default)

# apt-get install linux-image-2.6.32-5-686-bigmem
# apt-get install udev
During installation:
“Services to restart for GNU lib library upgrade": If cron is default - choose this

# reboot
5) # apt-get dist-upgrade

During installation:
“Use dash as the default system shell /bin/sh": Your choice - default is Yes.
“Chainload from menu.lst" - No ←—————————————————————————– THIS IS NOT DEFAULT. When I used YES my VM didn't boot.
“Migrate legacy boot sequencing to dependency-based sequencing” - Your choice - default is Yes.
“Configuring grub-pc: “Linux command line:”; console=hvc0 is OK.

# upgrade-from-grub-legacy
During installation:
GRUB install devices: Choose /dev/xvda with Space and OK.
DO NOT DELETE menu.lst

# reboot
If you install XenServer Tools you will downgrade your version and this is not recommended. Keep the latest one from step 2 in this guide. If you reinstall them just upgrade them to the latest with
# apt-update ; apt-get upgrade Don't forget to reboot after any XenServer Tools installation.

Дальше можно обновиться и до Wheezy

После чего можно обновить список репозиториев, для этого везде где встречаем в файле /etc/apt/sources.list squeeze (stable) необходимо заменить на wheezy (testing).

Далее не забываем обновить информацию о доступных пакетах в наших репозиториях:
bash:

aptitude update

Следующим нашим шагом будет обновление менеджеров пакетов, которые в процессе установки и обновление последующего софта должны работать, как пологается в Debian Wheezy (Testing):
bash:

aptitude install apt aptitude dpkg

Теперь можно обновить и весь дистрибутив:
bash:

aptitude dist-upgrade

После чего для уверенности в полном обновлении можно сделать:
bash:

aptitude full-upgrade

После всей установки, возможно, что некоторый софт используемый до обновления окажется удаленным, для его использования, просто необходимо его установить по новой через менеджер пакетов (переживать не стоит, если не удаляли конфиги, то все настройки остануться неизменными и переустановки не будет заметно

Discussion

Enter your comment. Wiki syntax is allowed:
O A D X L
 
linux_faq/обновление-виртуальнои-машины-xenserver-5-5-debian-5-lenny-до-debian-6-squeeze.txt · Last modified: 2015/04/09 14:08 (external edit)