При подключении клиентского компьютера с Windows XP и Citrix Receiver 4.2 (и более новыми) к опубликованным ресурсам возникают ошибки:

SSL 6
Ошибка 1110

Обычно причин две.

  • Просроченные корневые сертификаты
  • Слишком новый Citrix Receiver. С Windows XP нормально работает receiver не новее версии 4.1

Взять его можно тут: Citrix Receiver for Windows 4.1_14.1.2.3.zip
Или тут: Citrix Receiver for Windows 4.1_14.1.2.3.zip

, 2020/03/17 21:52

Здравствуйте, уважаемый Михаил! Есть ли возможность задружить клиент Citrix, работающий в WinXP, с сервером, который поддерживает только TLS 1.2? Например, если прописать а регистре XP поддержку TLS 1.2? Клиент 4.1, похоже TLS 1.2 не поддерживает. Есть надежда на 4.3, но не могу его найти.

, mike@autosys.tk, 2020/03/18 06:44, 2020/03/18 06:45

День добрый, Дмитрий!
Вот тут: https://support.citrix.com/article/CTX232266 приведены минимальные версии Citrix Receiver, поддерживающие TLS 1.2.
Судя по всему вам нужен Citrix Receiver 4.2.100.
По поводу включения TLS 1.2 в Windows XP - первая же ссылка в гугле: https://www.google.com/search?client=ubuntu&channel=fs&q=TLS+1.2+windows+XP&ie=utf-8&oe=utf-8

, 2020/03/18 16:43

Вероятно, Citrix Receiver 4.3 должен быть на исошнике Citrix Xendesktop 7.7 или 7.8. Из тех времен у меня сохранилися исошники 7.5, 7.6 и 7,9. Но там кажется версии Receiver 4.2 и 4.4

, 2020/03/18 18:18

Михаил, спасибо огромное, что откликнулись!

Видимо, если что-то и может помочь в моем случае с XP, так это версия 4.2.100, та самая первая с TLS 1.2. Ее найти пока не могу, но нашел интересный ресурс со списком всех версий ресивера и ссылками на сохраненные дистрибутивы, хотя часть из них не открывается: https://www.app-v.be/citrix/citrix-clients-list/ (Надеюсь, не сочтете рекламой, на версию 4.2 там как раз битая ссылка, но 4.3.100 - рабочая).

Версия 4.3 пока работать отказывается и вылетает, она, вероятно, еще более новая для XP, чем 4.2, о чем вы изначально написали, но я нашел совет запустить Receiver Clean-up utility после установки предыдущих версий (а я еще ставил совсем старенькую 3.4), а также вручную удалить из регистра вот эту запись: HKEY_CLASSES_ROOT\Installer\UpgradeCodes\9B123F490B54521479D0EDD389BCACC1 (Нашел здесь: https://thatitblog.wordpress.com/2013/08/27/citrix-receiver-trickery-hdx-engine-has-stopped-working-configuration-manager-cannot-be-initialized/) После удаления записи (но без запуска утилиты очистки) версия 4.3 перестала вообще запускаться :) Попробую утилиту очистки и переустановку ресивера.

Подскажите, пожалуйста, Вы пишите: “Citrix Receiver 4.3 должен быть на исошнике Citrix Xendesktop 7.7 или 7.8…” Это ведь не значит, что с более “свежими” серверами 4.3 работать не будет?

P.S.: Интересуюсь отнюдь не из праздного любопытства: в связи с известными событиями и нарастающей паникой наша организация перешла на удаленный режим работы, и мне пока пришлось реквизировать новенький ноутбук сына, который идеален для игр и поддерживает все современные навороты, но для офисной бюрократической работы он не очень удобен. Однако наша ИТ-служба развела руками на все вопросы о поддержке XP, хоть и оказалось, что не я один такой ископаемый, кто до сих пор дома сидит на XP :)

, 2020/03/19 04:19
Подскажите, пожалуйста, Вы пишите: “Citrix Receiver 4.3 должен быть на исошнике Citrix Xendesktop 7.7 или 7.8…” Это ведь не значит, что с более “свежими” серверами 4.3 работать не будет?

Я не могу ручаться за новейшие версии (я просто перестал админить цитрикс пару лет назад), но до определенного момента старые версии Citrix Receiver нормально работали с более новыми версиями серверов. Так как архитектура Citrix модульная - она допускает смешивание в одной инсталляции старые и новые компоненты. Например - вполне нормально удавалось смешивать в одной инсталляции старые WebInterface (5.4 если правильно помню) и Citrix SecureGateway (вместо Storefront и Netscaler) с новыми Citrix XenDesktop 7.6 - 7.15.
На моей памяти нормально работали старые версии клиентов времён XenDesktop 5.6 с новыми фермами Xendesktop 7.6.

, 2020/03/19 04:29

поддержка XP, со стороны Citrix Receiver может упираться в версии компонентов .NET, установленные в XP. Я бы порекомендовал попытаться обновить .NET на машине до последней доступной версии. Какой именно - не знаю :)
Эксперименты, описанные в заметке, скорее всего я проводил году в 15-16. И уже на тот момент поддержка XP была завершена. Возможно, с тез пор что-то было сделано в части обратной совместимости - всё-таки Windows Embedded на базе XP поддерживалась дольше и на ней были тонкие клиенты с поддержкой протоколов Citrix…
Если вы работаете на старом ноуте, то ставьте на него linux - это максимально продлит ему жизнь :) Под linux есть нормально работающий Citrix Receiver

, 2020/03/19 04:33, 2020/03/19 04:38

Кстати! С того самого ресурса, я нормально смог скачать Citrix Receiver 4.2.0.10 - https://www.app-v.be/citrix-clients/Citrix_Client_14.2.0.10/CitrixReceiver.exe
А на более новый 4.2 рабочая ссылка доступна в таблице ниже - http://www.app-v.be/citrix-clients/Citrix_Client_14.2.100.14/CitrixReceiver4.2.100.14.exe

Enter your comment. Wiki syntax is allowed:
J C B B H
 
  • citrix/новый_citrix_reciever_и_windows_xp.txt
  • Last modified: 2019/02/11 09:13
  • (external edit)